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Exercise 1. Simple Registration Servlet 
 

บทนํา 
 ในตัวอยางนี้ เปนการศึกษาในเรื่องการสราง Servlet ที่สืบทอดมาจาก คลาส 
javax.servlet.http.HttpServlet โดยทําการ override (สืบทอด) เมธอด doGet และ doPost โดย เมธ
อดทั้งสอง จะทําการเรียกใชงาน เมธอดอื่น ที่ช่ือ processRequest ซึ่งมีกระบวรการสรางเอกสาร HTML 
กลับไปยังหนาจอผูใชงาน เปนขอความยืนยัน ที่แสดงคาของ patron id 
 
 

ขั้นตอนที่ 1 สราง Enterprise application และ Web projects 
 

1. เปดโปรแกรม WebSphere Studio Application Developer ผานกระบวนการดังนี้ 
o เลือกที่ เมนู Start->Programs->IBM WebSphere Studio->Application 

Developer 5.1.1 
o กําหนดคา “C:\ServletJSPlabs\workspace” ใหเปนพื้นที่ที่ใชในการพัฒนา

(workspace) ดังรูปที่ 1 หรือ อาจทําการคลิกปุม Browse… เพื่อเลือก workspace 
เมื่อเสร็จแลว ใหทําการคลิกปุม OK เพื่อยืนยัน 

 

 
รูปที ่1 แสดงหนาตางกําหนดคา workspace 

 
2. ในการเปดใชงาน WebSphere Studio Application Developer ในครั้งแรก ที่หนาจอหลัก 

ดานซายมือจะมีการแสดง J2EE perspective  
o ในสวนนี้จะมี title bar แสดงวา perspective อะไรที่กําลังแสดงผลอยู  โดยคุณอาจทํา

การเลือก Data, Debug, J2EE,  Java และ อื่นๆ ที่สามารถเลือกเพิ่มได 
o ถา title bar ไมแสดงขอความ J2EE ใหคุณทําการเลือก J2EE perspective จากเมนู 

Window->Open Perspective->Other และเลือก J2EE  
o Title bar จะแสดงขอความ J2EE และ J2EE perspective  
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รูปที ่2 แสดง J2EE perspective และ การเลือกเมนูเพื่อแสดง J2EE perspective 
 

3. ที่ตําแหนงของ J2EE perspective จะทําการสราง Enterprise application โดยตั้งช่ือวา 
LibraryEnterpriseApplication ซึ่งกําหนดเลือกเปน J2EE 1.3 Enterprise 
application 

o ในการสราง Enterprise application สามารถเลือกไดผานทางปุม Create an 
Enterprise Application หรือคลิกเลือกจากเมนู File -> New -> Enterprise 
Application Project เพื่อเปดหนาตางในการสราง Project ขึ้นมา 

 

 
รูปที ่3 แสดงปุม Create an Enterprise Application บนทูลบารส 

 
o ทําการคลิกเลือก Create J2EE 1.3 Enterprise Application Project แลวคลิก

ปุม Next ดังรูป 
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รูปที ่4 แสดงหนาตางเพื่อเลือกรุนของ J2EE 

 
o ในชองของ Project name ปอน LibraryEnterpriseApplication  

 

 
รูปที ่5 แสดงหนาตางเพื่อกําหนดชื่อโปรเจค 
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o คลิกปุม Finish 

 
4. ทําการตรวจสอบวามีการสราง J2EE 1.3 Enterprise Application ที่ช่ือวา 

LibraryEnterpriseApplication โดยที่ยังไมมี Application Modules, Connector 
Modules, Web Modules,  EJB Modules, Databases หรือ Servers อยูภายใตโปรเจค ที่
สรางใหม 

 
o ในชองของ J2EE Hierarchy ในสวนของ  J2EE perspective คุณสามารถเปดดูใน

สวนของรายการ LibraryEnterpriseApplication ซึ่งจะแสดงรูป icon ที่มีเลข 
1.3 อยูภายใน โดยจะบงบอกถึงวาเปน J2EE 1.3 

 

 
รูปที่ 6 แสดง รายการของ LibraryEnterpriseApplication 

 
o ในสวนของรายการภายใน Project Utility JARs และ Utility JARs จะยังไมมี

รายการยอยอยูภายใน (ดังรูปที่ 6) 
o นั้นหมายถึงวา ยังไมการสราง Application Client Modules, Connection 

Modules, Web Modules, EJB Modules, Databases หรือ Servers ใดๆขึ้นเลย 
 

5. ขั้นตอนตอไป จะเปนการสราง Web project โดยตั้งช่ือวา LibraryWebProject โดยกําหนด
วาจะตองเปน Dynamic Web Project และจะตองมีความเกี่ยวเน่ืองกับ 
LibraryEnterpriseApplication ที่ไดสรางเอาไวแลว Web project สวนที่จะสรางนี้ 
จะตองกําหนดใหเปน context root ของ Library  

 
Information : context root จะถูกใชในสวนหน่ึงของ URL เมื่อมีการทํางานของ เซิรฟเล็ท ทั่วๆไปแลว
จะเปนรูปบบของการเรียกใช HTML, servlets และ JSP ซึ่งจะมีลักษณะดังนี้ : 
 

http://<hostname>/Library/<resourceName> 
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โดย hostname จะเปนช่ือของ โฮสท และ <resourceName> อาจะเปนช่ือของ HTML, servlets หรือ 
JSP ที่ตองการเรียกใชงาน สําหรับตอนนี้ คา<hostname> คือ localhost 
 
 

o ที่มุมมองของ J2EE perspective แลวทําการเลือกเมนู File->New->Dynamic 
Web Project เพื่อเปดหนาตาง New Web Project wizard 

o ปอน LibraryWebProject ลงในชองของ Project Name และทําการคลิกเลือกที่ 
Configure advanced options คลิกปุม Next ไปยังหนา  J2EE Settings 
Page 

 

 
รูปที่ 7 แสดงการกําหนดชื่อ Project และเลือก Configure advance options 

 
o ที่หนาตาง J2EE Settings Page ทําการเลือก LibraryEnterpriseApplication 

จาก EAR project 
o เลือก J2EE level เปน 1.3 
o ในชอง Context root เปลี่ยนคาเปน Library  ตรวจสอบตัวอักษรเล็กใหญ และการ

สะกดวาถูกตอง กอนจะทําขั้นตอนตอไป 
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รูปที่ 8 แสดงการกําหนดชื่อ Context 

 
o คลิกปุม Finish เพื่อสราง Web project 

 
6. สิ้นสุดการสราง LibraryWebProject ขึ้นมา จะมีหนาตางแสดงขอความ เพื่อยืนยันการเปลี่ยน 

web perspective (มุมมองแบบเว็บ)  ใหทําการคลิกเลือก Do not show this message 
again แลวคลิกปุม Yes เพื่อยืนยัน มุมมองของ Web perspective มีเครื่องมือในการสราง 
servlets, JSPs และ HTML files รวมทั้งไฟลตางๆที่จําเปนในการพัฒนาเว็บ 

 

 
รูปที่ 9 แสดงหนาตางยืนยันการเลือก web perspective 

 
7. สังเกตไดวา LibraryWebProject จะประกอบดวยหลายๆโฟลเดอร Java Resources, 

WebContent และ Libraries โดย Java Resources จะเปนที่เก็บของโคด servlet สวน 
WebContent จะแสดงเนื้อหาที่จะทําการเพิ่มเขาไปใน WAR ไฟลสําหรับ web module นี้ เมื่อ
คุณทําการ deploy ตัวของ enterprise application ของคุณ และสําหรับ Libraries (ที่อยูภายใต 
Java Resources) จะเก็บรายการของ JARs ที่ใชสําหรับการทํางานของระบบ  
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รูปที่ 10 แสดง Web perspective 

 
 

ขั้นตอนที่ 2 สราง Registerpatron servlet 
 

หลักจากที่ไดทําการสราง enterprise application และ Web project เปนที่เรียบรอยแลว ตอไปคุณ
จะสามารถเพิ่ม Web component(องคประกอบของเว็บ เชน HTML,JSPs และ servlet) ตางๆเขาสู 
Web project ได (ในที่นี้จะทําการสราง servlet) 
 
1. ทําการเปดและเลือกไปที่ Web perspective  

o เลือกจากเมนู Window->Open Perspective->Web 
2. สราง Java package ใหมเปน com.ibm.library.servlets 

o คุณสามารถสราง Java package ใหม ไดจาก perspective ใดๆก็ได แตใน Java 
perspective จะมี toolbar สําหรับจัดการมาใหดวย สําหรับตอนนี้คุณอยูใน Web 
perspective คุณจะตองทําการเรียกใชงาน wizard จากเมนู File->New->Other… 
จะปรากฏหนาตาง Select 

o เลือกเมนู Java จากทางดานซาย และเลือก Package จากทางดานขวา แลวคลิก Next 
เพื่อเปดหนาตาง Create a Java package 
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รูปที่ 11 แสดงหนาตาง Select ในการสราง Java package ใหม 

 
o คลิกปุม Browse เพื่อเปดหนาตาง Folder Selection  
o ทําการคลิกเปดเขาไปใน LibraryWebProject และเลือก JavaSource คลิกปุม OK 
o ในชอง Source Folder จะปรากฏขอความ LibraryWebProject/JavaSource 
o กําหนดคาในชอง Name เปน com.ibm.library.servlets และคลิกปุม Finish เพื่อ

สราง Java Package ใหม 
 

 
รูปที่ 12 แสดง การกําหนดที่เก็บ และ การกําหนดชื่อ Java Package ที่จะสรางใหม 
 

3. สราง servlet ที่ช่ือ RegisterPatron ใน package ช่ือ com.ibm.library.servlets โดย 
servlet ใหมจะทําการ extend (สืบทอด) จากคลาส javax.servletl.http.HttpServlet และ 
implement interface คลาส javax.servlet.Servlet โคดภายในจะทําการ Override 2 เมธ
อด คือ doGet() และ doPost() หลักจากนั้นจะสราง map servlet ของคุณกับ URL pattern 
ต้ังช่ือเปน /Register 

 
o จาก Web perspective ทําการเลือกเมนู File->New->Servlet เพื่อเปดหนาตาง 

New Servlet wizard 
o ตรวจสอบคาในชอง Folder =  /LibraryWebProject/JavaSource และ Java 

package = com.ibm.library.servlets 
o ในชองของ  Class name กําหนดคาเปน RegisterPatron และในชอง Superclass 

จะตองมีคาเปน javax.servlet.http.HttpServlet แลวคลิกปุม Next  
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รูปที่ 13 แสดงกําหนดคาเพื่อสราง RegisterPatron servlet 

 
o ตรวจสอบคาในชอง Interface ใหเปน javax.servlet.Servlet และมีการคลิกเลือก 

modifies ในสวนของ  public สวนของ method stub มีการเลือก doGet() และ 
doPost() สุดทายตรวจสอบวา มีการคลิกเลือก Inherited abstract methods ไว 
จากนั้นทําการคลิกปุม Next 

o ที่หนาตาง Deployment descriptor ตรวจสอบวามีการคลิกเลือก Add to web.xml 
ไว  โดยไฟล Web Deployment Descriptor นี้ จะใชในการ map ระหวาง ช่ือ URL 
กับคลาส servlet  ในที่นี้คือ คุณมี servlet ที่ช่ือ RegisterPatron และคา default 
ของชื่อ URL จะเปน /RegisterPatron 

o ทําการเปลี่ยน URL mapping จาก /RegisterPatron ไปเปน /Register จากนั้นทํา
การคลิกปุม Finish เพื่อสราง servlet 

 

 
รูปที่ 14 แสดงการแกไข URL Mapping สําหรับ Register servlet 

 
4. สวนของ edit window จะทําการแสดงคลาส RegisterPatron ที่เราไดทําการสรางขึ้นมา และ 

ทําการตรวจสอบไฟล RegisterPatron.java วาอยูใน Java Package ที่ 
com.ibm.library.servlets หรือไม  
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รูปที่ 15 แสดง คลาส RegisterPatron จากหนาตาง Web perspective 

 
 
 

5. ทําการดับเบิ้ลคลิก ที่ Web Deployment Descriptor ซึ่งอยูใน แท็บ Project Navigator 
บน Web perspective จากนั้นที่หนาตางดานขวา ใหคลิกแท็บ Servlets และเลือกที่ 
RegisterPatron  servlet ทําการตรวจสอบในสวนของ URL Mappings วามีรายการของ 
/Register หรือไม  

 

รูปที่ 16 แสดงหนาตาง Web Deployment Descriptor  
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6. ทําการดับเบิ้ลคลิกบน EAR Deployment Descriptor ที่เปนรายการอยูใน 
LibratryEnterpriseApplication  เพื่อแกไข application.xml โดยเลือกแท็บ Module 
และเลือก LibraryWebProject.war ทําการตรวจสอบคาในชอง Context Root วาเปน 
/Library หรือไม จากนั้นใหทําการปดหนาตางนี้ออกไป  

 

 
รูปที่ 17 แสดงหนาตาง Application Deployment Descriptor 

 
Information : LibraryEnterpriseApplication  จะแสดง EAR และจะประกอบดวย Web 
Module ช่ือ LibraryWebProject  ซึ่ง LibraryWebProject จะเปน WAR ไฟล และมี 
Context root เปน /Library  โดยจะทําการ map การทํางานไปยัง LibraryWebProject  
นอกจากนั้น ภายใน LibraryWebProject จะมี URL Mapping ระหวาง /Register กับ 
com.library.library.servlets.RegisterPatron  โดยผูใชงานจะเรียกผานทาง URL 
 
 http://<hostname>/Library/Register 
 
/Library จะเปนคาที่ทําให LibraryEnterpriseApplication ทําตามการรองขอ ดวย 
LibraryWebProject และ LibraryWebProject ไดทําการ map คาของ /Register ไปยัง 
servlet ที่มีช่ือวา com.ibm.library.servlets.RegisterPatron หลักจากนั้น Web container จะ
ทําการเรียกใช RegisterPatron servlet 
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ขั้นตอนที่  3 เพิ่มการทํางานใหกับ RegisterPatron servlet 
 
 Servlet นี้จะถูกเรียกใชงานเมื่อมีผูที่ตองการเปน สมาชิกหองสมุด ทําการลงทะเบียน กับทางหองสมุด 
โดยในขั้นตอนนี้จะเปนขั้นตอนงายๆ การสราง id ใหมและแสดงผลการทํางาน วาไดเพิ่มสมาชิกเสร็จสิ้น ใหผูใช
ไดรับทราบ ซึ่งการทํางานในสวนจริงจะอยูใน แบบฝกหัดตอไป 
 

1. เปดไฟล RegisterPatron.java เพื่อการแกไข 
2. ทําการเปด Outline view 

o ทําการคนหาในสวนตางๆของหนาจอ หากไมพบสวนหนาตางที่ช่ือ “Outline” ใหทําการ
เลือกที่เมนู Window->Show View->Outline จะมีหนาตางปรากฏทางดานซายมือ 
ซึ่งภายในจะประกอบดวยชอง Page Data และ Gallery  

 

 
รูปที่ 18 แสดงหนาตาง Outline View 

 
3. Outline view จะมีการทํางานที่ประสานกับชองแกไขโคด โดยเมื่อคุณทําการเลือกไปยัง รายการเมธ

อด ที่อยูใน Outline view ทางดานของ ชองแกไขโคดจะทําการเลื่อนเพื่อแสดงโคดในสวนเมธอด
นั้นๆ ใหเห็นทันที  

4. ทําการแกไขเมธอด doGet และ doPost  ใหเรียกใชเมธอด processRequest โดยมี req และ 
resp เปนคาอารกิวเมนต ของเมธอด  จะสังเกตุไดวา ขอความ processRequest จะมีเสนขีดเสนใต
สีแดง และมีรูปหลอดไฟ แสดงใหเห็นดังรูปที่ 19  
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รูปที่ 19 แสดงการแกไขโคด 

 
5. ทําการคลิกที่รูปหลอดไฟ จะปรากฏหนาตาง ใหทําการดับเบิ้ลคลิกบน Create method 

‘processRequest(..)’ (คุณสมบัติการทํางานแบบนี้เรียกวา Quick Fix และชวยใหการทํางานดี
ขึ้น)  

 

 
รูปที่ 20 แสดงการคลิกเพื่อสรางเมธอด processRequest 

 
6. สักเกตุไดวาในสวนช่ือไฟลของโคด(ทางดานบนสุด) เมื่อมีการแกไขโคดแลวจะปรากฏขอความเปน 

*RegisterPatron.java ซึ่งเครื่องหมาย * จะหายไปเมื่อคุณทําการ บันทึกการแกไขโคด 

Created by Mr.Suppakit Thongdee Website: http://www.sourcecode.in.th -13-



 - 14 - 

o คุณสามารถบันทึการทงานไดหลายวิธี อาจกดปุม คีย Ctrl+S ,ผานทางเมนู File->Save , 
ผานทางปุม Toolbar หรือ ผานทางการคลิกเลือก Save จาก context menu ภายในสวน
แกไขโคด 

 
7. การแกไข เมธอด processRequest จําเปนจะตองใชคลาส PrintWriter จากคลาส 

HttpServletResponse ซึ่งเปนพารามิเตอรของเมธอดนี้ นอกจากนี้ ยังจําเปนจะตองรับคา id 
ใหมผานทางเมธอด LibraryIdGenerator.generatedId โดยเมธอด generatedId จะ
เปนแบบ static ซึ่งจะสงคาที่เปน int กลับมา 

 
Information : การทํางานของ Quick Fix (แสดงผานทาง หลอดไฟสีเหลือง) จะชวยในการพัฒนา ถา
คุณประกาศคลาสที่ไมมี  ประกาศคลาสผิด เรียกใชเมธอดที่ยังไมมีสรางไว หรือขอผิดพลาดอื่นๆ จะมีการ
แสดงหลอดไฟล ที่พรอมใหคุณคลิกและเลือกแนวทางแกไขที่มีให มาใหกับคุณเพื่อเลือกวิธีการแกไข ที่
เหมาะสมตอไป 
 

 
o การแกไข เมธอด processRequest โดยทําการดึงคลาส PrintWriter จากมาจากคลาส 

response ของ servlet โดยใชเมธอด getWriter() 
 

PrintWriter out = resp.getWriter(); 
 

o ใช Quick Fix ในการเพิ่มการ import คลาส java.io.PrintWriter และเพิ่มการ 
throws ใหกับเมธอด 

 

 
รูปที่ 21 แสดงการคลิกเพื่อเพิ่มคลาส PrintWriter 

 

 
รูปที่ 22 แสดงการคลิกเพื่อเพิ่ม throws ใหกับเมธอด processRequest 
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o ขั้นตอนตอไป จะเปนการรับคา id จากเมธอด LibraryIdGenerator.generateId 
int id = LibraryIdGenerator.generateId(); 

o สุดทายจะเปนการสรางเอกสาร HTML ที่จะแสดงผลการทํางาน ใหทําการตรวจวาไดมีการ
เพิ่มไฟล Master.css เขามาดังรูปที่ 23 และทําการเพิ่มโคด ตอไปนี้เขาไป 

 

 
รูปที่ 23 แสดงตําแหนงไฟล Master.css 

 
 
  out.println("<HTML>"); 
  out.println("<HEAD><TITLE>Patron added</TITLE></HEAD>"); 
  out.println("<LINK rel=\"stylesheet\" type=\"text/css\"" + 
   "href=\"/Library/theme/Master.css\">"); 
  out.println("<BODY>"); 
  out.println("<P>"); 
  out.println("Partron with id "+id+" has been added."); 
  out.println("</BODY>"); 
  out.println("</HTML>");  
 

o ทําการบันทึกการเปลี่ยนแปลง และตรวจสอบวามีขอผิดพลาดอะไรบาง นอกเหนือจาก
ขอผิดพลาดบรรทัดของ “LibraryIdGenerator cannot resolved” 
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ขั้นตอนที่  4 สรางคลาส LibraryIdGenerator และเมธอด 
generateId 
 
ขั้นตอนตอไป เปนการสรางคลาส LibraryIdGenerator โดยจะไปสรางไวใน package ของ 
com.ibm.library.servlets โดยคลาสจะประกอบดวยสเตติกเมธอดเพียง เมธอดเดียว ที่ช่ือวา 
generatedId ซึ่งจะสงคาของ id ของสมาชิกหองสมุดกลับมา 
 

1. ทําการสรางคลาส LibraryIdGenerator โดยจะไปสรางไวใน package ของ 
com.ibm.library.servlets ซึ่งสามารถใช Quick Fix ในการสรางได 

o ทําการคลิกที่รูปหลอดไฟ (Quick Fix) ที่อยูในหนาบรรทัดแรกของ เมธอด 
LibraryIdGenerator.generateId ภายในไฟล RegisterPatron.java 

o ดับเบิ้ลคลิกที่ Create class ‘LibraryIdGenerator’ จะปรากฏหนาตาง Java 
Class wizard ทําการตรวจสอบคาตางๆ และคลิก Finish คลาส 
LibraryIdGenerator จะถูกสรางและจะแสดงในชองแกไขโคด ไฟล 
LibraryIdGenerator.java 

 

 
รูปที่ 24 แสดง การเลือกรายการเพื่อสรางเมธอดใหม 

 
2. ทําการสรางเมธอด public static generateId ภายในคลาสของ LibraryIdGenerator 

และเมธอด generateId จะสงคา int กลับมา แตในขั้นตอนนี้จะสง คา 0 กลับมาเพียงเพื่อตองการ
ตรวจสอบการทํางานโดยรวมของทั้งหมดกอน 

 
o กลับไปเปดไฟลคลาส RegisterPatron แลวตรวจสอบขอผิดพลาด วายังเปนขอผิดพลาด

ที่แจงวา เมธอด generateId  ยังไมถูกสรางขึ้น 

o ใช Quick Fix ในการสรางเมธอด generateId ภายในคลาส LibraryIdGenerator 

o คุณจะถูกกําหนดใหกลับไปเปดหนาตางแกไขโคด LibraryIdGenerator.java  

o ทําการตรวจสอบวาเมธอดสงคา 0 กลับหรือไม (return 0) 

o ทําการบรรทึกคลาส LibraryIdGenerator จะตองมีรายการขอผิดพลาดใน Tasks 
view 
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ขั้นตอนที่  5 สราง Server Project สําหรับการทดสอบงาน 

 

ในการเรียกใชงาน servlet คุณจําเปนจะตองสราง และ ปรับแตงคา ของ Server Project โดยมีวิธีในการ
สรางที่เร็ว แตหากวาคุณตองการควบคุมการทํางานที่มีความซับซอนของ คาการปรับแตง Server แลวหละก็ 
วิธีนี้จะไมเหมาะกับงานคุณ 

1. ทําการเปดหนา Server perspective และสราง Server Project ใหม โดยต้ังช่ือเปน 
LibraryServerProject 

o เลือกจากเมนู Window->Open Perspective->Server เพื่อเปลี่ยนไปยัง Server 
perspective 

 

 
รูปที่ 25 แสดงหนาตาง Server Perspective 

 
o เลือกที่จะคลิกปุม Create Server Project จาก toolbar หรือ คลิกจากเมนู File-

>New->Server Project เพื่อเปดหนาตาง Create a New Server Project 
o กําหนดชื่อของโปรเจคเปน LibraryServerProject และคลิกปุม Finish เพื่อสราง  

 

 
รูปที่ 26 แสดงหนาตางการสราง Server Project 
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2. สราง Server และ กําหนดคาปรับแตงของ Server ใหม และกําหนดชื่อเปน LibraryServer 

ซึ่งจะเปน WebSphere Version 5.1 Test Environment ในการสราง 
LibraryServer จะตองสรางไวภายใน Library ServerProject  และกําหนดให 
LibraryServer ใชงาน พอรทหมายเลข 80 

o คุณสามารถคลิกเลือกที่ปุม Create Server and Server Configuration จาก 
toolbar หรือเลือกกจากเมนู  File->New->Server and Server 
Configuration จะมีการแสดหนาตาง Create a New Server and Server 
Configuration ออกมา 

o กําหนดชื่อเซิรฟเวอรเปน LibraryServer และตรวจสอบวา คาของ Folder เปน 
LibraryServerProject 

o ทําการคลิกเปดรายการของ WebSphere version 5.1  
o เลือกที่ Test Environment 
o คลิกปุม Next  

 

 
รูปที่ 27 แสดงการ สรางโปรเจค Server เพื่อทดสอบการทํางาน 

 
o เปลี่ยนคาของ HTTP port number เปน 80 และคลิกปุม Finish เพื่อสราง Server 

และ Server configuration 
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รูปที่ 28 แสดงการกําหนดหมายเลข port ของ Server 

 
3. ขั้นตอนแกไขเพื่อปรับแตงเพื่อให LibraryServerProject มีการติดตอทํางานรวมกับ 

LibraryEnterpriseApplication ผานทางการกําหนดคาของ LibraryServer 
o เปดไปที่หนาตาง Server Configuration และคลิกเปดรายการตางๆของ Server 
o คลิกเลือกที่ LibraryServer และคลิกเมาสขวา 

 

 
รูปที่ 29 แสดงการเพิ่ม project เขาสู Server 
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o เลือก Add and remove project จากเมนู pop-up จะปรากฏหนาตาง Add and 
Remove Projects และทําการเลือก LibraryEnterpriseApplication ที่อยูดาน
ซายมือ จากนั้นคลิกปุม Add เพื่อทําการเพิ่มโปรเจคไปยังดานขวา แลวคลิกปุม Finish 

 

 
รูปที่ 30 แสดงการเพิ่ม Project ที่ตองการทดสอบเขาสู Server 

 

 
รูปที่ 31 แสดง Project ที่ถูกเพิ่มเขามาเพื่อทดสอบ 

 
 
 
 

 

Created by Mr.Suppakit Thongdee Website: http://www.sourcecode.in.th -20-



 - 21 - 

ขั้นตอนที่  6 การทดสอบ servlet 
 
Servlet จะถูกเรียกผานทาง เว็บบราวนเซอรโดยมี URL ที่มีการ map เอาไว ซึ่งขณะนี้ hostname คือคําวา 
“localhost”, context root คือ Library  และมี mapping name เปนคําวา “Register” เมื่อตองการสั่งทํางานจะผานทา
ทาง URL: 
 
 http://localhost/Library/Register
 

1. ทําการเปด WebSphere Test Environment จากหนาตางของ Server perspective เพื่อสั่ง
ให RegisterPatron servlet ทํางาน 

o ทําการเลือกไปที่หนาตาง Server perspective  
o คนหาคลาส RegisterPatron จาก LibraryWebProject จาก 

com.ibmlibrary.servlets และทําการคลิกเลือก 

 

 
รูปที่ 32 แสดงการเลือกเพื่อสั่ง run servlet 

 

o คลิกเมาสขวา และเลือก Run on Server จากเมนู context จะปรากฏหนาตาง Server 
Selection 

 

 
รูปที่ 33 แสดงการเลือกรายการ Run on Serve… 

 
o เลือกรายการ LibraryServer จากรายการของ Use an existing server 

o ตรวจสอบรายการ Set Server as project default (do not prompt) วาถูกเลือก
อยู 

o คลิกปุม Finish เพื่อสั่งให Servlet ทํางาน 
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รูปที่ 34 แสดงการเลือกรายการ Server 

 

เมื่อทําการเริ่มตนการทํางานของ WebSphere Test Environment โดยที่ยังไมมีการเรียกใชงานมากอน
หนานี้  

1) โปรเจคจะถูกสงผานเขาสู server 
2) Server (WebSphere Application Server)เริ่มตนการทํางาน 
3) ปรากฏหนาตางเว็บบราวนเซอร 
4) เว็บบราวนเซอรทําการเรียกใชงานผาน URL ของ servlet 
5) Servlet จะถูกเรียกใหทํางาน และจะเริ่มตนทํางาน 
6) Servlet แสดงผลการทํางานที่หนาตางเว็บบราวนเซอร 

 
Information  : ถาคุณไมสามารถสั่ง run servlet ได ใหทําการตรวจสอบ เว็บบราวนเซอรวาไมมีการ 
กําหนดใช proxy ไวหรือไม นอกจากนี้ใหทําการตรวจสอบวา มีการทํางานของ Web Server อยูบนเครื่อง
หรือไม 

 
2. จะสังเกตุไดวาขอความที่แสดงบนเว็บบราวนเซอร มีคา id เปน 0 ซึ่งไดจาก เมธอด 

LibraryIdGenerator.generatedId ที่ไดสรางขึ้น 
3. ทําการหยุดการทํางานของ LibraryServer 

o ที่หนาตาง Server perspective ทําการคลิกเลือกเปลี่ยนจาก Console view ไปเปน  
Server view  

o คลิกเลือก LibraryServer จากรายการที่แสดง จากนั้นใหคลิกปุม Stop the server 
จากปุม ทูลบาร  

 

 
รูปที่ 35 แสดงการหยุดการทํางานของ Library Server 
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ขั้นตอนที่  7 ปรับปรุงเมธอด LibraryIdGenerator.generateId() 
 
ถึงขั้นตอนนี้ คุณสามารถสั่ง run servlet ได และตอไปคุณจะตองทําการสราง id คาใหมสําหรับผูที่มา
ลงทะเบียนของหองสมุด 

1. ทําการแกไขเมธอด LibraryIdGenerator.generateId เพื่อใหสรางคาตัวเลขจํานวนเต็มบวก ที่
มากกวา 0 ซึ่งในตัวอยางในแบบฝกหัดถัดไป คุณจะนําคานี้มาจาก ฐานขอมูล แตสําหรับตอนนี้ เราจะ
ทําแคเพียงการสุมคา ขึ้นมาคานึง 

o ทําการแกไขคลาส โดยเปดไฟล LibraryIdGenerator.java และเปลี่ยนแปลงคา 
return ของเมธอด generateId ตามนี้ 

 
return (new Double((Math.floor(1000000*Math.random())))).intValue(); 

 

 
รูปที่ 36 แสดงหนาตางของ Navigator view แสดงไฟล LibraryIdGenerator.java 

 
o บันทึกไฟล จะตองไมมีขอผิดพลาดในโคดที่แกไขลงไป 

 

ขั้นตอนที่  8 ทําการทดสอบ RegisterPatron กับเมธอด 
LibraryIdGenerator.generateId() ที่ไดปรับปรุง  
 

1. ตรวจสอบวาไดเปดหนาตาง Server perspective ไว แลวทําการ run RegisterPatron  
o คลิกเลือก RegisterPatron จาก Navigator view แลวคลิกขวา เลือก Run on 

Server จากเมนู pop up 
o Server จะถูกเรียกใหเริ่มตนทํางาน และแสดงคาที่ไดบนเว็บบราวนเซอร 

2. คาที่ไดใหมจะตองไมเทากับ 0 แตจะเปนจํานวนเต็มบวกที่ไดจากการสุม 
3. ที่หนาตาง Web Browser view ถาคุณทําการคลิกปุม Refresh the current page คุณก็จะ

ไดคา id ใหมแสดงออกมา (มีโอกาส 1 ใน ลานครั้ง ที่จะมีคาซ้ํากัน) 
4. ทดลองเรียกใชงาน servlet ผานทางเว็บบราวนเซอร โดยมี URL เปน 

http://localhost/Library/Register 
o เปดโปรแกรม Internet Explorer และปอน URL ของ Servlet เขาไป 
o หากไมไดติดตั้งโปรแกรม Internet Explorer เอาไว ใหทําการเรียกใช Web Browser 

ตัวอื่น และปอน URL เขาไป 

Created by Mr.Suppakit Thongdee Website: http://www.sourcecode.in.th -23-



 - 24 - 

 

 
รูปที่ 37 แสดงผลที่ไดเมื่อเรียก servlet ผานทาง Internet Explorer 

5. หยุดการทํางานของ Server และปดหนาตางแกไข และเว็บบราวนเซอร 
6. สิ้นสุดกระบวนการสราง servlet  ตัวแรกของคุณ 

 

END OF LAB 
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